Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N×MN\times M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x,y)(x, y) is firing at time tt, the grid which is adjacent to this grid will fire at time t+1t+1 which refers to the grid (x+1,y),(x1,y),(x,y+1),(x,y1)(x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)
You can assume that the grass in the board would never burn out and the empty grid would never get fire.
Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.
Then T cases follow, each case contains two integers NN and MM indicate the size of the board. Then goes N line, each line with M character shows the board. ‘#’ Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.
1<=T<=100,1<=n<=10,1<=m<=101 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
…#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

Translation

给一张平面地图,'#‘表示草地,’.'表示空地。两个人FatFat brotherbrotherMazeMaze,觉得找分别找一块草地放把火,火会向上下左右的草地蔓延,每前进一格需要一分钟,问至少需要几分钟把草地烧光。
两人可能会选择同一块草地,火是烧不到空地上的。

Idea

暴力枚举地图上的两块草地组合,两块草地同时入队进行BFSBFSBFSBFS完成后检查是否所有的草地都被访问过,如果没有就继续枚举,否则更新答案。

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
#include<cstring>
#include<cstdio>
#include<iostream>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;
const int N=12;
bool ok;
struct state
{
int x,y;
int step;
}grass[N*N];//储存每一块草地
bool vis[N][N];//记录已访问
int cnt;//草地的个数
char map[N][N];//储存地图
int n,m;
int times=0;
//位移矢量
const int dx[]={-1,1,0,0};
const int dy[]={0,0,-1,1};
int bfs(state a,state b)
{
//两个起点入队
queue<state>q;
q.push(a);
q.push(b);
vis[a.x][a.y]=1;
vis[b.x][b.y]=1;
int res=0;
while(!q.empty())
{
state now,nxt;
now=q.front();
int i;
for(i=0;i<4;i++)
{
nxt.x=now.x+dx[i];
nxt.y=now.y+dy[i];
nxt.step=now.step+1;
if(nxt.x<1||nxt.x>n)/*超出边界*/ continue;
else if(nxt.y<1||nxt.y>m)/*超出边界*/ continue;
else if(vis[nxt.x][nxt.y])/*已经访问过*/ continue;
else if(map[nxt.x][nxt.y]=='.')/*不可访问*/ continue;
else
{
vis[nxt.x][nxt.y]=1;
q.push(nxt);
res=max(res,nxt.step);//更新需要蔓延到的最长距离
}
}
q.pop();
}
return res;
}
void solve()
{
cnt=0;//初始化
cin>>n>>m;
int i,j;
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
cin>>map[i][j];
//存起点
if(map[i][j]=='#')
{
cnt++;
grass[cnt].x=i;
grass[cnt].y=j;
grass[cnt].step=0;
}
}
}
int ans=inf;
//小于两块草地,火势不需要蔓延
if(cnt<=2) ans=0;
else
{
//枚举
for(i=1;i<=cnt;i++)
{
for(j=i;j<=cnt;j++)
{
memset(vis,0,sizeof(vis));//初始化
bool ok=1;
int temp=bfs(grass[i],grass[j]);
int r,c;
//检查是否访问了所有草地
for(r=1;r<=n;r++)
{
for(c=1;c<=m;c++)
{
if(map[r][c]=='#'&&!vis[r][c])
{
ok=0;
goto out;
}
}
}
out:if(ok)/*全部草烧光了就更新*/ans=min(ans,temp);
}
}
}
//ans没有被更新过说明没有方案能将草烧光
if(ans==inf) printf("Case %d: -1\n",times);
else printf("Case %d: %d\n",times,ans);
}
int main()
{
int t;
cin>>t;
while(++times<=t) solve();
return 0;
}